resetting GNOME

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Sorry if this comes through multiple times, but I think something something is filtering my messages out.
Is there a way to completely reset GNOME? Right now, GNOME is completely
unusable for me. Something happened when I ran yum update last night. (e.g., clicking on a link in thunderbird results in "ERROR: The browser does not exist. Please reconfigure." and then right after, The Application "control-center" has quit unexpectedly.) Trying to set the theme in GNOME results in "The default theme schemas could not be found on your system. This means that you probably don't have metacity installed, or that your gconf is configured incorrectly."
I tried creating a new user and what comes up for that user is the Computer
icon and Trash icon with a completely black background. There is a small
panel, about 200 pixels across at the top without any icons in it. I assume
this is not normal. So, is there a way to reload everything from scratch? I
tried running this as well:
for i in /etc/gconf/schemas/*.schemas ; do
gconftool-2 --makefile-install-rule $i > /dev/null; done

but that results in numerous errors e.g.:

WARNING: failed to install schema
`/schemas/desktop/gnome/peripherals/mouse/motion_acceleration' locale
`gl': Unable to store a value at key
'/schemas/desktop/gnome/peripherals/mouse/motion_acceleration', as the
configuration server has no writable databases. There are some common
causes of this problem: 1) your configuration path file
/etc/gconf/2/path doesn't contain any databases or wasn't found 2)
somehow we mistakenly created two gconfd processes 3) your operating
system is misconfigured so NFS file locking doesn't work in your home
directory or 4) your NFS client machine crashed and didn't properly
notify the server on reboot that file locks should be dropped. If you
have two gconfd processes (or had two at the tim e the second was
launched), logging out, killing all copies of gconfd, and logging back
in may help. If you have stale locks, remove ~/.gconf*/*lo ck. Perhaps
the problem is that you attempted to use GConf from two machines at
once, and ORBit still has its default configuration that prevents
remote CORBA connections - put "ORBIIOPIPv4=1" in /etc/orbitrc. As
always, check the user.* syslog for details on problems gconfd
encountered. The re can only be one gconfd per home directory, and it
must own a lockfile in ~/.gconfd and also lockfiles in individual
storage locations such as ~ /.gconf

Any suggestions would be appreciated.


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux