Re: wifi, ndiswrapper and 2.6.17 kernels...

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Kim Lux <[email protected]> wrote:
I run FC4 on an HP ZD7280 laptop that has a Broadcom wifi modem in it.
I've been running it with ndiswrapper on a variety of kernels for the
last 2 years. It has worked great.
So, this weekend I upgraded to a 2.6.17 kernel and now wifi doesn't
work.  And I can't get it working.  I tried ndiswrapper versions 1.14
and 1.23.  uname -r  = 2.6.17-1.2143_FC4smp.

I heard that 2.6.17 ships with bcm43xx.   The driver files for my wifi
modem are bcmwl5 and bcmwl5a.

/sbin/lsmod | grep bcm43
bcm43xx               440009  0
ieee80211softmac       36673  1 bcm43xx
ieee80211              37641  2 bcm43xx,ieee80211softmac

/sbin/lsmod | grep ndiswrapper

What am I missing ?  How do I get it running ?

Check dmesg output. The only way I got bcm43xx to work on my HP zv6015 was by turning off WEP authentication at the AP. This may be a problem that is specific to my AP. You don't mention using fwcutter to set up the firmware for bcm43xx. fwcutter (available from extras I think) includes a README file regarding how to extract and then configure the firmware for the bcm43xx module. More documentation at You can also try a google search for "bcm43xx fwcutter".

Politics, n. Strife of interests masquerading as a contest of principles.
-- Ambrose Bierce

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux