Re: Kyum: /var/log/yum.log, could not be opened for reading.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sun, 2006-07-02 at 15:24 -0400

ron wrote:

   >>>> Hello,

   >>>> Kyum says "/var/log/yum.log  could not be opened for reading.".

    >>>> I can view the yum.log outside of kyum.

   >>>> Can anyone help?

    >>>> -ron-

ON Mon, 03 Jul 2006 08:56:32 +0100

Paul wrote:

    >>> If you have SELinux in enforcing mode, what's the output of:

    >>> # ls -lZ /var/log/yum.log $(which kyum)

    >>> Paul.

On Mon, 03 Jul 2006 09:54:17 -0400

ron wrote:

   >> Paul,

   >> SELinux is in enforcing mode.

   >> The output of:

   >> # ls -lZ /var/log/yum.log $(which kyum)

   >> IS:

   >> [root corefive ~]# ls -lZ /var/log/yum.log $(which kyum)

   >> -rwxr-xr-x  root root system_u:object_r:bin_t          /usr/bin/kyum

>> -rw------- root root system_u:object_r:rpm_log_t /var/log/yum.log

   >> [root corefive ~]#

On Mon, 03 Jul 2006 15:10:58 +0100

Paul wrote:

> Hmm, it appears that kyum is just a GUI front-end for yum (i.e. it invokes yum itself to do the work), compared with say

> yumex, which uses yum APIs but not the yum executable itself. So kyum doesn't need the same SELinux context as yum,

> unlike yumex. Apart, that is, from the need to read rpm/yum log files.

> So give this a try:

> # chcon -t rpm_exec_t /usr/bin/kyum

> Then try kyum again, and make sure it still works OK for installing/removing packages (try it on something you don't care

> much about), as well as being able to read the yum log.

> Paul.


I tried:

# chcon -t rpm_exec_t /usr/bin/kyum

But I still get:

"/var/log/yum.log  could not be opened for reading."

So I removed kyum, erased all remaining files, reinstalled kyum, and set SELinux to permissive.

But still no luck.


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux