RE: Grub failing to work

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



It sounds like GRUB is messed up. Try This:

1) Take your master CD-DVD for the Distro and boot from it.
2) When it comes up Type F5 and then type Linux Rescue
3) Hit [Enter] --> Continue --> /mnt/sysimage
4) Type chroot /mnt/sysimage
5) Type grub-install /dev/sda [in my case -- in your case it may be sdb or whatever].
That *should* reinstall GRUB, you may then need to go to /boot/grub and edit
by hand [or not] menu.lst.
That *should* fix it... but then again, it might not, but at this point it
does not sound like you have anything to lose by doing a little bit of
hacking. In the worst case you might need to do a re-install of FC5, in that
case do this:
Start the Install process, yada, yada, yada, when it get to the point where
it asks you what type of install you want to do select *custom* --> *manual*
-->then *edit* your partitions. BUT *DO NOT* FORMAT / !!! Yada, yada, yada.
You are now at the package installation: Select *only* the packages for your
GUIs (Kde, GNOME, etc) , sys admin, and sys tools, unmark all other
packages, start the install. This will overwite your startup files including
GRUB, while preserving the data on / [root] As a word of warning when you
edit the partitions also make sure you *DO NOT* FORMAT /home !! If you do
your toast, unless you have a backup of /home, in which case you would have
to do a restore of /home ( which can be a pain in the @$$, especially if you
backed it up with partimage as I sadly found out on kernels above 2.6.10.
TIP: depending on what you use for your backup, the most reliable is to back
up using the tar command.
But first start by doing a re-install of GRUB, the take the more drastic
action if necessary.
Hope this helps.

Bob



Hi folks,

FedoraCore5_64

Grub on this box did not work ever since running "yum update" updating
"kernel-2.6.16-1.2133_FC5" a few days ago.  On starting the PC only
with "GRUB" popup on a black screen without other messages.  Typing
does not work, keystroke without function.  I have to run a boot floppy
to start the box/PC.

# uname -a
Linux localhost.localdomain 2.6.16-1.2133_FC5 #1 SMP Tue Jun 6 00:51:53
EDT 2006 x86_64 x86_64 x86_64 GNU/Linux

# rpm -qa kernel
kernel-2.6.16-1.2133_FC5
kernel-2.6.16-1.2122_FC5

The boot floppy was created on this box with
# grub
grub> root (hda0,0)
setup (fd0)


I tried to fix the problem with the boot floppy without success.  Steps
performed as follows;

# fdisk -l
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14        1734    13823932+  83  Linux
/dev/sda3            1735        3008    10233405   83  Linux
/dev/sda4            3009        9729    53986432+   5  Extended
/dev/sda5            3009        3262     2040223+  82  Linux swap /
Solaris

HD - SATA interface
/boot on /dev/sda1


After starting the box/PC with the boot floppy

1)
On Konsole;

# grub
Probing devices to guess BIOS drives. This may take a long time.

	GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word,
TAB
   lists possible command completions.  Anywhere else TAB lists the
possible
   completions of a device/filename.]

grub> root (hd0,0)
root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
grub> setup (hd0,0)

setup (hd0,0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... yes
 Checking if "/grub/stage2" exists... yes
 Checking if "/grub/e2fs_stage1_5" exists... yes
 Running "embed /grub/e2fs_stage1_5 (hd0,0)"... failed (this is not
fatal)
 Running "embed /grub/e2fs_stage1_5 (hd0,0)"... failed (this is not
fatal)
 Running "install /grub/stage1 (hd0,0) /grub/stage2 p /grub/grub.conf
"... succeeded
Done.


Exited grub and rebooted the box/PC.  Still failed to boot the box/PC
with only "GRUB" displayed on a black screen, no other messages.
Keystroke did not work.


2)
On Konsole

# grub
Probing devices to guess BIOS drives. This may take a long time.

	GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word,
TAB
   lists possible command completions.  Anywhere else TAB lists the
possible
   completions of a device/filename.]

grub> root (fd0)
root (fd0)
 Filesystem type unknown, using whole disk

grub> setup (hd0,0)
setup (hd0,0)
Error 17: Cannot mount selected partition

Failed.  Whether I need to mount the /boot partition (/dev/sda1) first
before running "grub"?  The HD is working.  Would it make confusion
resulting in re-installing the complete FC5_64.


Besides I can't mount the boot floppy, either as root or as user, to
copy "grub" from it on /boot

$ cat /etc/fstab
...
....
/dev/fd0    /mnt/floppy		auto	noauto,owner,user,kudzu 0 0

However I can mount a floppy with .txt files on it only by running
"mount /mnt/floppy"

It looks strange to me.  Would the boot floppy only contain an image.

Please advise.  TIA

B.R.
SL

--
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux