Re: Yum Update Dep error

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 2006-06-07 at 21:35 +0200, Jeremy Thompson wrote:
> 
> 
> On 6/7/06, Todd Zullinger <[email protected]> wrote:
>         -----BEGIN PGP SIGNED MESSAGE-----
>         Hash: SHA1
>         
>         Jeremy Thompson wrote:
>         > Ok,
>         >  I can't get it to update with any of the fixes posted -
>         >
>         > yum --exclude=evolution* update
>         > yum --exclude=evolution/* update 
>         > yum --exclude=evolution update
>         > yum --exclude=evolution* update
>         > yum --exclude=evolution*,evolution update
>         
>         You need a backslash in front of the *, otherwise the shell
>         will try
>         to expand it.  Alternatively, you can quote the string and
>         skip the 
>         backslash.
>         
>         Either of the following work fine:
>         
>             yum --exclude "evolution*" update
>             yum --exclude evolution\* update
> 
> No such luck, I copy/pasted straight from your email - 
> 
> --------------------------
> 
> [[email protected] yum.repos.d]# yum --exclude evolution\* update
> Loading "fastestmirror" plugin
> Loading "installonlyn" plugin
> Setting up Update Process
> Setting up repositories
> core
> [1/3]
> extras
> [2/3]
> updates
> [3/3] 
> Loading mirror speeds from cached hostfile
> Reading repository metadata in from local files
> Excluding Packages in global exclude list
> Finished
> Resolving Dependencies
> --> Populating transaction set with selected packages. Please wait. 
> ---> Package postgresql-libs.i386 0:8.1.4-1.FC5.1 set to be updated
> ------<SNIP>------
> ---> Package pirut.noarch 0:1.0.3-0.fc5 set to be updated
> --> Running transaction check
> --> Processing Dependency: gstreamer-tools >= 0.10.4 for package:
> gstreamer
> --> Processing Dependency: libpisock.so.9 for package: evolution
> --> Restarting Dependency Resolution with new changes.
> --> Populating transaction set with selected packages. Please wait. 
> ---> Package gstreamer-tools.i386 0:0.10.4-1 set to be updated
> --> Running transaction check
> --> Processing Dependency: libpisock.so.9 for package: evolution
> --> Finished Dependency Resolution
> Error: Missing Dependency: libpisock.so.9 is needed by package
> evolution
> 
> [[email protected] yum.repos.d]# yum --exclude "evolution*" update
> Loading "fastestmirror" plugin
> Loading "installonlyn" plugin 
> Setting up Update Process
> Setting up repositories
> core
> [1/3]
> extras
> [2/3]
> updates
> [3/3] 
> Loading mirror speeds from cached hostfile
> Reading repository metadata in from local files
> Excluding Packages in global exclude list
> Finished
> Resolving Dependencies
> --> Populating transaction set with selected packages. Please wait. 
> -----<SNIP>-----
> ---> Package pirut.noarch 0:1.0.3-0.fc5 set to be updated
> --> Running transaction check
> --> Processing Dependency: gstreamer-tools >= 0.10.4 for package:
> gstreamer
> --> Processing Dependency: libpisock.so.9 for package: evolution
> --> Restarting Dependency Resolution with new changes.
> --> Populating transaction set with selected packages. Please wait.
> ---> Package gstreamer-tools.i386 0:0.10.4-1 set to be updated
> --> Running transaction check
> --> Processing Dependency: libpisock.so.9 for package: evolution
> --> Finished Dependency Resolution
> Error: Missing Dependency: libpisock.so.9 is needed by package
> evolution 
> 
>   Please tell me it's something I did wrong so we can all ridicule me
> together and laugh at my newbishness.  So very true about syntax..
> usually I am so good about it... *sigh
> 
>   Thanks for looking into this, is there something else I can try? 

You're in an unfortunate position here. I think you have the original
FC5 version of evolution installed, which was linked against
libpisock.so.9. There were so many issues with that version of the
library that an updated was released to downgrade it to libpisock.so.8.
In order to do this downgrade on your system, you'll need to update all
of the packages that depend on libpisock. That includes evolution, but
you can't do that easily because of the evolution-data-server
brokenness.

Try this:
# wget
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/i386/evolution-2.6.1-1.fc5.2.i386.rpm
# yum localinstall evolution-2.6.1-1.fc5.2.i386.rpm

See how that goes.

Paul.



[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux