How to configure MADWIFI + WPA-SUPPLICANT [was Re: Howto configure Wireless Card in FC5]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



The first is to be sure that "madwifi" is your driver.
The second is install it.

I suppose that you are using the livna madwifi-ng package for FC5, in that case, when ath_pci is loaded it creates an "ath0" interface.
The ath_pci module, at load time, creates a "ficticious" driver called
"wifi0", you don't need to touch it, then using madwifi tools you
creates as many "athN" interfaces as you want in the mode as you want.
By default, in modprobe.conf you can see that ath0 is created when
ath_pci loads as "station mode" interface. In your case, will be at all.
The next is configure your wireless access. In FC5 you have 4 methods:

1) Traditional method using wireless tools (use "man iwconfig" and use it).
2) Using system-config-network (or gnome version), it is very limited tool for wifi configuration, but could be the necesary. 3) I remember somebody says something about a "KWifiManager" usually used under KDE (I don't tried it).
4) Using wpa_supplicant.


To install without problems, I recomend you add the livna repository (it is compatible with FC5 repositories).
Then install these packages:
   kmod-madwifi
   madwifi
   wpa_supplicant

The first is for your kernel modules, the second the madwifi utils (I don't need it for usual operations).
About configuration, I use gnome-config-network (or how it is named) to
put the IP config and the basic wireless params. The wireless params
leave all in auto or only putting the correct essid.
Then configure your /etc/sysconfig/wpa_supplicant to say the interface
and the driver to use.
Then configure your /etc/wpa_supplicant.conf file to put your wifi
network parameters.
Then activate the wpa_supplicant service to run at boot and start the
service.
That's all.

The summary (you must be root to run many of next commands) :

1) Install livna repository:
   wget http://rpm.livna.org/livna-release-5.rpm
   rpm -ivh livna-release-5.rpm

2) Install madwifi driver, madwifi utils and:
   yum -y install kmod-madwifi madwifi wpa_supplicant

3) Perhaps you will need to reboot your system at this point to allow the load of madwifi driver, but instead, you can try to use:
   modprobe ath_pci

4) Using any tool, configure your IP options in your ath0 driver.

5) Configure your /etc/sysconfig/wpa_supplicant file: Be sure the lines are:

INTERFACES="-iath0"
DRIVERS="-Dmadwifi"

The old lines, use coments to disable them.

6) Configure your /etc/wpa_supplicant.conf file for your network. Sorry, no help, this file is very personal, but default file contains many examples for many configurations.
7) Be sure you run your wpa_supplicant service when system boot:

   chkconfig --level 345 wpa_supplicant on

8) Run the wpa_service to enable the wifi link:

   service wpa_supplicant start

This step is only to force the wpa_supplicant start now, you don't need it every system start.
ADITIONAL NOTES:
   1) These steps could be general for many drivers.
2) Use madwifi and wpa_supplicant official web pages to search about config options and troubleshooting.
   3) NDISWRAPPER I think you use as the "last" resource.
   4) Say us if this help you when you have your wifi card running.
   5) Sorry for my english.

Regards

Chris Jones escribió:
I have FC5 on a vanilla Athlon 64  CPU. I also have a Netgear WPN311 NIC.

My question is-
How do I get this NIC to talk to my LAN which is hosted with a Netgear DG834PN ADSL/Router. I have tried to install the madwifi rpms from atrpms, but the wireless card does not seem to be seen.
The output from iwconfig is:-
lo        no wireless extensions.

eth1      no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

... from ifconfig is:
eth1      Link encap:Ethernet  HWaddr 00:0F:EA:8C:2E:52
         inet addr:192.168.0.22  Bcast:192.168.0.255  Mask:255.255.255.0
         inet6 addr: fe80::20f:eaff:fe8c:2e52/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:552268 errors:0 dropped:0 overruns:0 frame:0
         TX packets:885713 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:340400719 (324.6 MiB)  TX bytes:107766838 (102.7 MiB)
         Interrupt:19 Base address:0xc000

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:980429 errors:0 dropped:0 overruns:0 frame:0
         TX packets:980429 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:6920054619 (6.4 GiB)  TX bytes:6920054619 (6.4 GiB)

... output from uname -a is:
Linux x.x.x 2.6.16-1.2111_FC5 #1 SMP Thu May 4 21:16:04 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux


All help will be very gratefully received.

Thanks
Chris Jones

--
   Samuel Díaz García
    Director Gerente
ArcosCom Wireless, S.L.L.

CIF: B11828068
c/ Romero Gago, 19
Arcos de la Frontera
11630 - Cadiz

http://www.arcoscom.com

mailto:[email protected]
msn: [email protected]

Móvil: 651 93 72 48
Tlfn.: 956 70 13 15
Fax:   956 70 34 83


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux