Re: extended attributes

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, 2006-05-09 at 07:21, James Wilkinson wrote:
> Russell Strong wrote:
> > I tried editing a file where I didn't have write permission on the directory, 
> > only have write permission on the file.  That worked as I expected, the EAs 
> > were preserved and the inode did not change.  Anyone know why vim behaves 
> > differently when it has write permissions for the directory?  Is this a vim 
> > "bug" ( not behaving the way ?most? users expect ) or is there a reason?
> Oh yes, there certainly is a reason....
> As I understand it, the normal way that vim saves a file is to create a
> new file, give it the appropriate ownership and permissions (and these
> days SELinux attributes), write everything into that file, and rename it
> to the desired filename.

It should copy over the original in all cases where it can't
duplicate it exactly.  For example the file is owned by
someone else but you have write permission - or there are
multiple links to the same file.  If it doesn't do that for
EA's that it can't reproduce it is just another place that
they aren't well integrated into the distribution.

  Les Mikesell

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux