Re: hosed RPM

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Andy Green wrote:
Mark Haney wrote:
Okay, my very first hosed rpmdb.  I tried rebuilddb, no go.  I tried
initdb /then/ rebuilddb no go.  Any other ideas?  Fortunately, this
isn't a production system (yet) so I can blow it away if I need to.  I
was running up2date on the box from ssh and for some reason sshd died in
the middle of it.

up2date :-O  Use yum.

Check your /var/log/messages for, eg, memory-related problems that
provoked things to blow up in the first place.

What exactly are the symptoms when you try, for example,

rpm -qa


rpm -qa gives me a package list like it should. This is what I get when I up2date:

RPM error.  The message was:
Could not determine what version of Red Hat Linux you are running.
If you get this error, try running

               rpm --rebuilddb

Interdum feror cupidine partium magnarum Europae vincendarum

Mark Haney
Sr. Systems Administrator
ERC Broadband
(828) 350-2415

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux