Re: MySQL upgrade

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Craig White <craigwhite@xxxxxxxxxxx>
Reply-To: For users of Fedora Core releases <fedora-list@xxxxxxxxxx>
To: For users of Fedora Core releases <fedora-list@xxxxxxxxxx>
Subject: Re: MySQL upgrade
Date: Wed, 08 Mar 2006 14:00:49 -0700

On Wed, 2006-03-08 at 20:01 +0000, Jim Douglas wrote:
> >From: Boris Glawe <boris@xxxxxxxxxxxxxx>
> >Reply-To: For users of Fedora Core releases <fedora-list@xxxxxxxxxx>
> >To: For users of Fedora Core releases <fedora-list@xxxxxxxxxx>
> >Subject: Re: MySQL upgrade
> >Date: Wed, 08 Mar 2006 18:22:06 +0100
> >
> >
> >>
> >>
> >>I was following those instruction and it said..
> >>
> >>user mysql does not exist, using root
> >>
> >>Is this a security problem ? Should I cread a mysql user and rebuild -bb?
> >>
> >>Thanks,
> >>Jim
> >>
> >>
> >no, it's no problem.
> >
> >The instructions on the specified link are very complicated.
> >
> >Simply download the MySQL...src.rpm and build it with
> >
> >rpmbuil --rebuild MSQL....src.rpm
> >
> >greets Boris
> >
> >--
> >fedora-list mailing list
> >fedora-list@xxxxxxxxxx
> >To unsubscribe:
> When I run,
> mysql_fix_privilege_tables --password=XXXXXXX
> I get this,
> This script updates all the mysql privilege tables to be usable by
> MySQL 4.0 and above.
> This is needed if you want to use the new GRANT functions,
> CREATE AGGREGATE FUNCTION, stored procedures, or
> more secure passwords in 4.1
> You can safely ignore all 'Duplicate column' and 'Unknown column' errors
> because these just mean that your tables are already up to date.
> This script is safe to run even if your tables are already up to date!
> ERROR 2002 (HY000): Can't connect to local MySQL server through socket
> 'car/lib/mysql/mysql.sock' (111)
> Got a failure from command:
> cat /usr/share/mysql/mysql_fix_privilege_tables.sql | /usr/bin/mysql
> --no-defaults --force --user=root --host=localhost --password=mypassword
> --database=mysql
> Please check the above output and try again.
> If you get an 'Access denied' error, you should run this script again and > give the MySQL root user password as an argument with the --password= option
> I tried,
> mysql_fix_privilege_tables --password=XXXXXXX
> mysql_fix_privilege_tables --password='XXXXXXX
> mysql_fix_privilege_tables --password="XXXXXXX"'
> When does this socket get created?
the socket

/var/lib/mysql/mysql.sock is created when mysqld service is started

above you have 'car/lib/mysql/mysql.sock' which looks like a problem.

I've never used the script to which you are referring but I've never
used MySQL 5.x either so don't go by me but I always simply consider the

mysql_install_db # creates the base db's

and check out /etc/my.cnf
# cat /etc/my.cnf
# Default to using old password format for compatibility with mysql 3.x
# clients (those using the mysqlclient10 compatibility package).



Note, old_passwords=0 is to use the new style mysql password hash
mechanism, old_passwords=1 is to maintain compatibility with MySQL v 3.x


fedora-list mailing list
To unsubscribe:

I downloaded the tar for the source code, unzipped and copied the support-files/my-medium.cnf into /etc/my.cnf and now it works.

The v. 4 config file doesn't work wih v.5. My webapp is back up and running but there are still issues, I cannot rebuild Postfix with this version of MySQL. I get the following error,

error: Failed dependencies: is needed by postfix-2.2.2-2.i386.rpm

I think this has to do with the fact that v5 of MySQL uses a different path to mysql.sock

# The MySQL server
port		= 3306
socket		= /tmp/mysql.sock


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux