Re: up2date: ImportError: /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Peter Connolly wrote:
After upgrading to RedHat Fedora Core 3, I run into the following
problem with up2date after filling in the 'su' password prompt:

- - - - - [[email protected] ~]$ up2date
Traceback (most recent call last):
File "/usr/sbin/up2date", line 27, in ?
from up2date_client import repoDirector
File "/usr/share/rhn/up2date_client/repoDirector.py", line 5, in ?
import rhnChannel
File "/usr/share/rhn/up2date_client/rhnChannel.py", line 10, in ?
import up2dateAuth
File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 5, in ?
import rpcServer
File "/usr/share/rhn/up2date_client/rpcServer.py", line 22, in ?
from rhn import rpclib
File "/usr/lib/python2.3/site-packages/rhn/__init__.py", line 11, in ?
import rpclib
File "/usr/lib/python2.3/site-packages/rhn/rpclib.py", line 14, in ?
import transports
File "/usr/lib/python2.3/site-packages/rhn/transports.py", line 24, in ?
import connections
File "/usr/lib/python2.3/site-packages/rhn/connections.py", line 14, in ?
import SSL
File "/usr/lib/python2.3/site-packages/rhn/SSL.py", line 15, in ?
from OpenSSL import SSL, crypto
File "/usr/lib/python2.3/site-packages/OpenSSL/__init__.py", line 11, in ?
import rand, crypto, SSL, tsafe
ImportError: /lib/libssl.so.4: undefined symbol: krb5_cc_get_principal
[[email protected] ~]$
- - - - -


I tried the approach of removing the krb lib entry from /etc/ld.so.conf:

http://www.redhat.com/archives/fedora-list/2004-January/msg00831.html

but still get this error.  I also tried upgrading 'up2date' to
up2date-4.3.69-1, the latest version that I could find.

Any ideas?  Thanks!
pc


I upgraded rpm-python and up2date started working again. This might not be your problem. It does not seem to relate to the errors though.


Jim



--
186,000 Miles per Second.  It's not just a good idea.  IT'S THE LAW.


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux