USB/ACPI problem on Compaq R3000z

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Since the volume is high on this mailing list while the signal-to-noise is 
often low, I would appreciate any communications on this to be done off-list 
(I will post any results to the list).

I have a Compaq R3000z (Athlon64) notebook.  There are multiple systems 
installed:  WinXP on a shrunk hda1, swap on hda2, a FC3 minimal install on 
hda3 as a boot director, FC3 i386 everything install on hda5 and FC3 x86_64 
everything install on hda6.  My problem(s) occur identically (as far as I can 
tell) on both the i386 and x86_64 systems.

Booting with ACPI=ON (actually specifying nothing at boot time):

1.  The integral synaptic touchpad is detected as a generic PS2 two-button 
input device.
2.  A USB (1.1) mouse is not detected/useable.
3.  USB 1.1 flash drive is not detected although USB 2.0 flash drives are 
detected and useable.

Booting with ACPI=OFF:

1.  The integral synaptic touchpad is not detected.
2.  The USB (1.1) mouse is detected an useable.  It can be hotplugged if not 
present at boot time.
3.  Both the USB 1.1 and the USB 2.0 flash drives are detected and useable.

Bug reports have been filed:

There are some bug reports filed at which may be the same 
thing or at least related.  However, nothing recent which sounds like this.

I also searched and came up with some reports indicating 
problems in the 2.5/2.6 kernel with USB/ACPI (one very old report pointed me 
in the right direction).

I have also tried these devices on a ASUS SK8V/Opteron system and everything 
worked fine there.  This "problem" seems to have been around for a while and 
I know that there are Compaq R3000z notebooks (or the HP equivalent) out 
there being used with FC3.  I am a bit surprised that this problem is not 
more widely known.

I am also interested in trying a "generic" kernel from if that is 
possible/practical.  Does anyone know if it is "safe" to run the generic 
kernel without all the Red Hat/Fedora Core patches (a lot fewer patches than 
SUSE run but nevertheless a significant number).

Any help will be appreciated.

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux