Re: Yum Update

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, Oct 15, 2003 at 05:45:29PM -0400, Met @ Uber wrote:
> Can I just change where my Yum is setup to get packages from to update
> from 94 to 95?  Or is that just a _really_ bad idea?

I think you can. I tried it on my test machine, which is an ancient PI
with just about a GB of installed Fedora on it. Your mileage almost
certanly will vary.

* Edit your update repository to point to the new version. BTW, it is
  not in the man page for yum.conf, but it appears yum accepts # as a
  comment character. This is handy for temporary hacks like this.

* Run "yum check-update". This will pull in the new headers and tell
  you what you have to update. Here is what I saw:

XFree86                             i386   4.3.0-37                 updates
XFree86-75dpi-fonts                 i386   4.3.0-37                 updates
XFree86-Mesa-libGL                  i386   4.3.0-37                 updates
XFree86-Mesa-libGLU                 i386   4.3.0-37                 updates
XFree86-base-fonts                  i386   4.3.0-37                 updates
XFree86-font-utils                  i386   4.3.0-37                 updates
XFree86-libs                        i386   4.3.0-37                 updates
XFree86-libs-data                   i386   4.3.0-37                 updates
XFree86-tools                       i386   4.3.0-37                 updates
XFree86-twm                         i386   4.3.0-37                 updates
XFree86-xauth                       i386   4.3.0-37                 updates
XFree86-xfs                         i386   4.3.0-37                 updates
acpid                               i386   1.0.2-3                  updates
bind-utils                          i386   9.2.2.P3-6               updates
comps                               i386   1:0.95-0.20031010        updates
coreutils                           i386   5.0-23                   updates
cpio                                i386   2.5-5                    updates
cpp                                 i386   3.3.1-6                  updates
db4                                 i386   4.1.25-10                updates
devlabel                            i386   0.42.05-2                updates
dhclient                            i386   1:3.0pl2-6.16            updates
elfutils                            i386   0.89-2                   updates
elfutils-libelf                     i386   0.89-2                   updates
filesystem                          i386   2.2.1-5                  updates
freetype                            i386   2.1.4-5                  updates
glibc                               i386   2.3.2-98                 updates
glibc-common                        i386   2.3.2-98                 updates
gmp                                 i386   4.1.2-7                  updates
groff                               i386   1.18.1-29                updates
hotplug                             i386   3:2003_08_05-1           updates
hwdata                              noarch 0.99-1                   updates
indexhtml                           noarch 2:0.95-2                 updates
initscripts                         i386   7.36-2                   updates
kernel                              i586   2.4.22-1.2088.nptl       updates
krb5-libs                           i386   1.3.1-6                  updates
kudzu                               i386   1.1.32-1                 updates
libgcc                              i386   3.3.1-6                  updates
libgcj                              i386   3.3.1-6                  updates
libjpeg                             i386   6b-29                    updates
libstdc++                           i386   3.3.1-6                  updates
libtiff                             i386   3.5.7-14                 updates
man                                 i386   1.5k-11                  updates
man-pages                           noarch 1.60-4                   updates
mkinitrd                            i386   3.5.14-1                 updates
mktemp                              i386   1.5.1-1                  updates
modutils                            i386   2.4.25-13                updates
ncftp                               i386   2:3.1.6-1                updates
net-snmp                            i386   5.0.9-1                  updates
nscd                                i386   2.3.2-98                 updates
openssl                             i386   0.9.7a-23                updates
pcre                                i386   4.4-1                    updates
perl                                i386   3:5.8.1-91               updates
portmap                             i386   4.0-57                   updates
prelink                             i386   0.3.0-8                  updates
procps                              i386   2.0.17-1                 updates
redhat-artwork                      i386   0.84-1                   updates
redhat-config-network-tui           noarch 1.3.7-1                  updates
redhat-config-securitylevel-tui     i386   1.2.10-1                 updates
redhat-config-xfree86               noarch 0.9.9-2                  updates
redhat-menus                        noarch 0.40-1                   updates
rhpl                                i386   0.117-1                  updates
run                                 i386   2.0-3                    updates
tzdata                              noarch 2003d-1                  updates
up2date                             i386   4.1.5-1                  updates
which                               i386   2.16-1                   updates
zlib                                i386                updates

* A quick ("yum check-update | grep -i kernel") check tells me that
  there is a kernel upgrade between .94 and .95.

* The first thing I did was "yum upgrade kernel". That worked just fine.

* After that, I ugraded the rest all in one swell foop. 

  Oddly enough, "yum check-update | grep -i release" did not show any
  new version of redhat-release, but there is one and it will be

* Since the release version should have changed, clean out all of your
  old headers. "yum clean all oldheaders" You might even kill off old
  directories. "rm -r /var/cache/yum/base /var/cache/yum/updates". I'm
  no yum guru, but it certainly seems harmless so far. One advantage
  of a local repository ( is
  that you can kill off the headers in your test machine as much as
  you like.

* /etc/redhat-release is now a symlink to /etc/fedora-release. On the
  off chance that the former will eventually go away (the package
  did), you might edit [main] in yum.conf to include
  "distroverpkg=/etc/fedora-release". Another that went away is

* The penultimate thing to do is edit your yum.conf to reflect
  possible changes in your repository locations. The $releasever and
  $basearch macros should handle the problem, but paranoids live

* Reboot and try it. X seems to be working and that's usually a good


Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email    / \    No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB

Attachment: pgpdSmGBnVgCU.pgp
Description: PGP signature

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux