Re: getting Nvidia 2D/3D to work (M.Hockings)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Thanks David,

That did the trick all works just peachy again! I think the key was the removal of the XFree86-Mesa-libGL package. Is there any downside to doing this, I have not noticed any problems though.

Even Quake 3 works now!

Kind regards,

Mike

David Utidjian wrote:

Mike,

I also went through similar tribulations since installing RC1 and the 4496 version of the Nvidia drivers. I went to the Nvidia forum and there are some pretty goofy methods in there (recompile the kernel with gcc-3.3.2 and whatnot). The basic method (see below) is identical to the regular Nvidia install instructions in the README from Nvidia with two added steps. Pretty (relatively) simple.
I also had some problems with running Quake3. Very messed up. I haven't tried UT2K3 yet. I also have a dual PIII system not an Athlon.


Please let me know if this works.

[Begin included instructions]

This is what I did (all root commands are prepended with a # sign):

0. Download the file NVIDIA-Linux-x86-1.0-4496-pkg2.run from
http://download.nvidia.com/XFree86/...0-4496-pkg2.run
and put it somewhere useful (/tmp or /home/downloads or whatever).

1. Logout of the system then Ctrl-Alt-F1 to get to a virtual console and log in as root.

2. Switch runlevels from 5 to 3 this will stop X (as root):

# telinit 3

It will take a few seconds as things shutdown/restart.
Hit [Enter] if you don't get a prompt back right away.
This will stop X "gracefully". X will restart automatically on reboot OR the command startx OR the command telinit 5.


3. Set the C compiler environment variable to gcc32 (it is currently gcc by default).

# export CC=gcc32

4. Remove the XFree86-Mesa-libGL package:

# rpm -e --nodeps XFree86-Mesa-libGL

5. Now run the Nvidia driver installer as usual:

# cd /path/to/where/you/put/it
# sh NVIDIA-Linux-x86-1.0-4496-pkg2.run

Answer the usual questions and it should build and install correctly.

6. Make a backup copy of your "known good" /etc/X11/XF86Config file:

# cd /etc/X11
# cp XF86Config XF86Config.bak

7. Edit your XF86Config file so that it will use the nvidia driver rather than the stock nv driver. This will be in 'Section "Device"' and there will be a line like this:

Driver "nv"

Change that line to:

Driver "nvidia"

You may also need to add and/or comment out some options in the 'Section "Module"' part of that file. For details on this see the README file which should be in /usr/share/doc/NVIDIA_GLX-1.0/README. Once you are finished editing the XF86Config file save it.

8. Test the new driver:

# startx

Which should start X. If X starts up OK try opening a terminal and type in the command:

# glxgears

If that works fine then you are done installing the driver.

9. Logout of X. You should be abck at a command prompt. Then restart the GUI login for X:

# telinit 5

The GUI login for X should start up.

10. One last thing... you left a virtual console logged in as root. You propably don't want to forget and leave that open so....

Ctrl-Alt-F1
# exit
Alt-F7

Will log you out as root and return you to the GUI login.


Note: The above method is really pretty simple. There are only two added steps from the method one would use in previous versions of Red Hat 9 or earlier... they are steps 3 and 4. If you have installed Nvidia drivers in Red Hat (or other distros) before then you will already be familiar with most of this. Even if you are familiar with the Nvidia Linux drivers you should read the README and other docs because there are a lot of very cool features you may want to try out. This feature set changes with each release of the drivers.


[End included post]

-DU-...etc...


-- fedora-list mailing list [email protected] http://www.redhat.com/mailman/listinfo/fedora-list






[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux