Averatec laptop: ethernet (sis900) stopped working...

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hey all,

So this averatec 3120V booted fine the first reboot after installing.  I
ran up2date, and grabbed a bunch of yarrow rpms over the net from
freshrpms and did a bit of websurfing...

Then, it hung on the next boot.  Turns out that pcmcia does have to be
disabled to avoid hanging at boot.  So I skipped it doing an interactive
boot, then disabled it for all runlevels using chkconfig, and it reboots
again.

Now there's something hosed with the ethernet.

This page http://home.ettus.com/sotec-linux/ mentions some sort of
unhealthy relationship between pcmcia and the ethnernet.

from dmesg:

sis900.c: v1.08.06 9/24/2002
PCI: Found IRQ 11 for device 00:01.1
PCI: Sharing IRQ 11 with 00:01.6
PCI: Sharing IRQ 11 with 00:03.0
divert: allocating divert_blk for eth0
eth0: ICS LAN PHY transceiver found at address 1.
eth0: Using transceiver found at address 1 as default
eth0: SiS 900 PCI Fast Ethernet at 0xd000, IRQ 11, 00:40:45:11:3e:4c.
divert: freeing divert_blk for eth0
ip_tables: (C) 2000-2002 Netfilter core team
ip_conntrack version 2.1 (1791 buckets, 14328 max) - 292 bytes per
conntrack
sis900.c: v1.08.06 9/24/2002
PCI: Found IRQ 11 for device 00:01.1
PCI: Sharing IRQ 11 with 00:01.6
PCI: Sharing IRQ 11 with 00:03.0
divert: allocating divert_blk for eth0
eth0: ICS LAN PHY transceiver found at address 1.
eth0: Using transceiver found at address 1 as default
eth0: SiS 900 PCI Fast Ethernet at 0xd000, IRQ 11, 00:40:45:11:3e:4c.
eth0: Media Link Off

[[email protected] Desktop]$ /sbin/lsmod
Module                  Size  Used by    Not tainted
trident                33364   1 (autoclean)
ac97_codec             16712   0 (autoclean) [trident]
pcigame                 2632   0 (autoclean) [trident]
gameport                3380   0 (autoclean) [pcigame]
soundcore               6468   3 (autoclean) [trident]
ide-cd                 34432   0 (autoclean)
cdrom                  34560   0 (autoclean) [ide-cd]
sd_mod                 13420   0 (autoclean)
usb-storage            70624   0
lp                      8580   0 (autoclean)
parport                37056   0 (autoclean) [lp]
autofs                 12084   0 (autoclean) (unused)
sis900                 15756   0
ipt_REJECT              4216   1 (autoclean)
ipt_state               1080   2 (autoclean)
ip_conntrack           28136   1 (autoclean) [ipt_state]
iptable_filter          2444   1 (autoclean)
ip_tables              15008   3 [ipt_REJECT ipt_state iptable_filter]
sg                     35436   0 (autoclean)
scsi_mod              110280   3 (autoclean) [sd_mod usb-storage sg]
microcode               4188   0 (autoclean)
keybdev                 2656   0 (unused)
hid                    23908   0 (unused)
usb-ohci               21544   0 (unused)
usbcore                78752   1 [usb-storage hid usb-ohci]
mousedev                5268   1 (autoclean)
input                   5888   0 (autoclean) [keybdev hid mousedev]
sis                    53664   1
sisfb                 250476   0 [sis]
agpgart                55492   3
ext3                   71300   2
jbd                    51052   2 [ext3]


[[email protected] Desktop]$ /sbin/ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:40:45:11:3E:4C  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xd000 

Frustrating, it _was_ working fine that one time...

Any ideas?

I tried adding MEDIA=100baseT to /etc/sysconfig/network-scripts/ ...

-- 
Peter L. Hurd                                  Department of Psychology
Assistant Professor                               University of Alberta
Ph 780.492-3578, Fax 780.492-1768                     Edmonton, Alberta
http://www.psych.ualberta.ca/~phurd                      T6G 2E9 Canada





[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux