Re: NIS files

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Weird... I am almost sure I had hand edited the /etc/yp.conf file when I installed the mail server we have (it's running redhat 9)... Thx for the help...

Pedro Macedo

Message: 29
Date: Wed, 03 Dec 2003 17:57:59 -0800
From: Gordon Messmer <[email protected]>
To: [email protected]
Subject: Re: NIS files
Reply-To: [email protected]

Pedro Fernandes Macedo wrote:

I'm installing the first fedora server in my work and I found something odd... I edited the /etc/yp.conf and added the settings to my domain:
domain NIS.mydomain.com broadcast
Then , when I tried to start ypbind , it didn't start... It only worked when I edited /etc/sysconfig/network and added the line NISDOMAIN=NIS.mydomain.com .
Is there any reason to do this?



Yes. The init scripts set your "domainname" if you have NISDOMAIN in the network sysconfig file. Otherwise, you have no "domainname" setting, and NIS doesn't work. There's nothing odd about it.



And another question: why is there the directory /etc/rc.d/init.d ? Why arent all the initscripts be in /etc/init.d , just like it was in redhat ?



The structure has been as it is for a very long time. Red Hat always had /etc/rc.d/init.d, and later FHS required /etc/init.d and /etc/rcx.d


Red Hat symlinked those to the locations they'd been using, and that's the way it is now.





[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux