Re: RTNETLINK answers: Invalid argument

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



>> Sun, 2003-11-30 at 14:33, Dennis Kaptain wrote:
>> I'm a long time RHL user and I just installed fedora.
>> I have a cable modem connected to eth0 which uses dhcp.
>> eth1 (static 192.168.1.1) goes to a hub and then 2 other
>> computers 192.168.1.2 and 192.168.1.3
>>  
>> I can connect anywhere on the net using eth0 (including this list thank 
God!).
>> I can ping eth1 OK.
>> ping the other 2 PC's says "icmp_seq=0 Destination Host Unreachable"
>> the other PC's pinging me have same result.
>>  
>> service network start  :reports no errors.
>> ifup eth1 reports: "RTNETLINK answers: Invalid argument"
>> I have narrowed that down to> /etc/sysconfig/network-scripts/ifup-routes
>> line 33
>> handle_file $file $1
>> put an echo in and $file is "/etc/sysconfig/network-scripts/route-eth1"
>> and $1 is "eth1"
>> the contents of /etc/sysconfig/network-scripts/route-eth1
>> [[email protected] network-scripts]# cat route-eth1
>> GATEWAY0=192.168.1.1
>> NETMASK0=255.255.255.0
>> ADDRESS0=192.168.1.3
>>  
>> I don't know what the ADDRESS0 item but it doesn't look right,
>> I changed it to 192.168.1.1 and that didn't help.
>>  
>> What do these values in route-eth1 need to be?
>> What else can I look for?
>> I already verified that it is not a firewall issue.
>> 
>> BTW: all this worked before the re-install.
>
>A couple of items you can check:As root, do an ifconfig eth1 to verify 1) 
>that your eth1 nic is up and2) has the correct seetings.  
>
>Verify the settings in the other two computers.  (ifconfig if linux andeither 
>winipcfg or ipconfig for Win98/ME and WinXP respectively.) I would also 
>recommend using redhat-config-network for configuring yournetwork devices.  
>Clifford
>
>This message is digitally signed. Click the lock icon for more information.

Clifford,
thanks for the speedy reply. I am pretty sure I found my real problem. It 
looks here like eth1 a 3c590, and es1371 (my sound card) are "sharing" IRQ10. 
To the best of my knowledge... You can't do that!!  Now I found a problem but 
I still don't know how to fix it. Both cards are PnP PCI cards without 
jumpers to set the IRQ. Is there a way to forceably assign IRQs to PnP PCI 
cards in software?

[[email protected] proc]# cat interrupts
           CPU0       CPU1
  0:       4995       5789    IO-APIC-edge  timer
  1:         72         97    IO-APIC-edge  keyboard
  2:          0          0          XT-PIC  cascade
  5:       3703        121   IO-APIC-level  eth0
  8:          1          0    IO-APIC-edge  rtc
 10:          1         16   IO-APIC-level  eth1, es1371
 11:          0          0   IO-APIC-level  usb-uhci
 12:         68        217    IO-APIC-edge  PS/2 Mouse
 14:        182        219    IO-APIC-edge  ide0
 15:       6657       5925    IO-APIC-edge  ide1
NMI:          0          0
LOC:      10694      10693
ERR:          0
MIS:          0

Thanks again
Dennis




[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux