Hi This patchset converts macros related to super_block handling into functions. Besides that it fixes some sparse warnings (23rd and 24th), improves coding style (1st) and fixes error handling (19th). Note that udf files has really long lines and these patches won't validate by checkpatch. I'm going to do more cleanups later. PS: This is the first time I use git-send-email - tell me if I do something wrong. Marcin Slusarz -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- [PATCH 24/24] udf: fix sparse warnings (shadowing & mismatch between declaration and definition)
- From: [email protected]
- [PATCH 23/24] udf: convert UDF_SB_FREE_BITMAP macro to udf_sb_free_bitmap function
- From: [email protected]
- [PATCH 22/24] udf: convert UDF_SB_ALLOC_BITMAP macro to udf_sb_alloc_bitmap function
- From: [email protected]
- [PATCH 21/24] udf: remove some UDF_SB_* macros
- From: [email protected]
- [PATCH 20/24] udf: convert UDF_UPDATE_UDFREV macro to udf_update_revision function
- From: [email protected]
- [PATCH 19/24] udf: check if udf_load_logicalvol failed
- From: [email protected]
- [PATCH 18/24] udf: convert UDF_SB_ALLOC_PARTMAPS macro to udf_sb_alloc_partition_maps function
- From: [email protected]
- [PATCH 17/24] udf: convert UDF_SB_VAT macro to udf_sb_vat_inode function
- From: [email protected]
- [PATCH 16/24] udf: convert UDF_SB_UDFREV macro to udf_sb_revision function
- From: [email protected]
- [PATCH 15/24] udf: convert UDF_SB_SERIALNUM macro to udf_sb_serial_number function
- From: [email protected]
- [PATCH 14/24] udf: convert UDF_SB_RECORDTIME macro to udf_sb_record_time function
- From: [email protected]
- [PATCH 13/24] udf: remove unused macros
- From: [email protected]
- [PATCH 12/24] udf: convert UDF_SB_LVIDIU macro to udf_sb_lvidiu function
- From: [email protected]
- [PATCH 11/24] udf: convert UDF_SB_LVID macro to udf_sb_lvid function
- From: [email protected]
- [PATCH 10/24] udf: convert UDF_SB_LVIDBH macro to udf_sb_lvid_bh function
- From: [email protected]
- [PATCH 09/24] udf: convert UDF_SB_LASTBLOCK macro to udf_sb_last_block function
- From: [email protected]
- [PATCH 08/24] udf: convert UDF_SB_ANCHOR macro to udf_sb_anchor function
- From: [email protected]
- [PATCH 07/24] udf: convert UDF_SB_SESSION macro to udf_sb_session function
- From: [email protected]
- [PATCH 06/24] udf: convert UDF_SB_PARTITION macro to udf_sb_partition function
- From: [email protected]
- [PATCH 05/24] udf: convert UDF_SB_NUMPARTS macro to udf_sb_num_parts function
- From: [email protected]
- [PATCH 04/24] udf: convert UDF_SB_VOLIDENT macro to udf_sb_volume_ident function
- From: [email protected]
- [PATCH 03/24] udf: convert some macros to inline functions
- From: [email protected]
- [PATCH 02/24] udf: rename UDF_SB to udf_sb
- From: [email protected]
- [PATCH 01/24] udf: fix coding style of super.c
- From: [email protected]
- [PATCH 24/24] udf: fix sparse warnings (shadowing & mismatch between declaration and definition)
- Prev by Date: Re: [patch] Make MMCONFIG space (extended PCI config space) a driver opt-in issue
- Next by Date: [PATCH 01/24] udf: fix coding style of super.c
- Previous by thread: ACPI or radeon: spontaneous reboot regression
- Next by thread: [PATCH 01/24] udf: fix coding style of super.c
- Index(es):