On Tuesday 13 November 2007, David Brownell wrote:
> So the point of these is to make it easier for platforms
> (or even just boards) to make sure the GPIO number space
> is densely packed, rather than loosely so? Paying about
> 2KBytes for that privilege. (Assuming a 32 bit system
> with 256 GPIOs.)
>
> I could see that being a reasonable tradeoff. I wouldn't
> have started there myself, but you know how that goes!
>
> Does anyone else have any comments on that issue?
Nobody else seems to have any comments on Eric's series
of patches to add a gpio_desc layer ... whereas, I was
looking at updating one platform, and got annoyed at some
stuff that would have been non-issues with them in place!
Eric, would you feel like rolling an all-in-one patch against
the gpiolib support from 2.6.24-rc3-mm? Including updated
versions of your patches:
- [PATCH 2/5] define gpio_chip.requested_str
(renaming it as "label" to match its usage)
- [PATCH 3/5] use a per GPIO "struct gpio_desc"
(but without that needless list; for debug,
just scan the gpio_desc list for the next
non-null chip)
- [PATCH] move per GPIO "is_out" to "struct gpio_desc"
(i.e. patch 4/5)
- [PATCH 5/5] move per GPIO "requested" to "struct gpio_desc"
(and "label" too)
along with removing the ARCH_GPIOS_PER_CHIP symbol, and
reducing ARCH_NR_GPIOS to a value which will waste less
space by default? (Like maybe 256.)
I think an all-in-one patch will be easier to review
and agree on including (or not).
- Dave
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]