On Tue, 09 Oct 2007 18:32:30 +0200, Oleg Verych said: > On Tue, Oct 09, 2007 at 06:06:05PM +0200, Joerg Roedel wrote: > > > cpu_has() returns int, > > > but would it be better to have something like > > > > > > if (!mce_disabled && > > > !(c->x86_capability & (X86_FEATURE_MCA | X86_FEATURE_MCE)) { > > > printk(KERN_INFO "CPU%i: No machine check support available\n", > > > smp_processor_id()); > > > > This looks complicated and is harder to read. Its exactly the purpose of the > > cpu_has() macro to avoid such constructs. > > It is done via test_bit(), which is designed for IO access with all that > `const volatile' stuff, 2 x unnecessary, can't be optimized here (IMHO). If this code is getting called often enough that optimization matters, you got *bigger* issues to worry about than optimization. Looks like it should only happen once at boot time.
Attachment:
pgpxlXFWwVcxs.pgp
Description: PGP signature
- Follow-Ups:
- Re: [PATCH 1/2] i386: mce cleanup part1: functional change
- From: Oleg Verych <[email protected]>
- Re: [PATCH 1/2] i386: mce cleanup part1: functional change
- References:
- [PATCH 0/2] i386: MCE updates
- From: "Joerg Roedel" <[email protected]>
- [PATCH 1/2] i386: mce cleanup part1: functional change
- From: "Joerg Roedel" <[email protected]>
- Re: [PATCH 1/2] i386: mce cleanup part1: functional change
- From: Oleg Verych <[email protected]>
- Re: [PATCH 1/2] i386: mce cleanup part1: functional change
- From: "Joerg Roedel" <[email protected]>
- Re: [PATCH 1/2] i386: mce cleanup part1: functional change
- From: Oleg Verych <[email protected]>
- [PATCH 0/2] i386: MCE updates
- Prev by Date: Re: [stable] [patch 08/12] NLM: Fix a circular lock dependency in lockd
- Next by Date: Re: OHCI root_port_reset() deadly loop...
- Previous by thread: Re: [PATCH 1/2] i386: mce cleanup part1: functional change
- Next by thread: Re: [PATCH 1/2] i386: mce cleanup part1: functional change
- Index(es):