Re: coding for optimizations (Re: [PATCH 1/2] i386: mce cleanup part1: functional change)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Oct 09, 2007 at 07:33:17PM +0200, [email protected] wrote:
> 	if (!mce_disabled) {
> 	if (!(c->x86_capability & (X86_FEATURE_MCA | X86_FEATURE_MCE)) {
> 		printk(KERN_INFO "CPU%i: No machine check support available\n",
>  			smp_processor_id());
> 		return;
> 	}
> 	/* function code */
> 	}

I have 2 problems with this way:

1) It is totally broken because c->x86_capability is not an integer but
   an *array* of integers. This is also the reason why test_bit() is used
   in cpu_has() and not plain logical operators.

2) It is still hard to read and breaks the kernel coding style.

But you are right with the redundant mca and mce variables. They are not
needed and I will inline the cpu_has() checks into the condition check.
I'll resubmit tomorrow.

-- 
           |           AMD Saxony Limited Liability Company & Co. KG
 Operating |         Wilschdorfer Landstr. 101, 01109 Dresden, Germany
 System    |                  Register Court Dresden: HRA 4896
 Research  |              General Partner authorized to represent:
 Center    |             AMD Saxony LLC (Wilmington, Delaware, US)
           | General Manager of AMD Saxony LLC: Dr. Hans-R. Deppe, Thomas McCoy


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux