On Wed, 2007-09-19 at 19:39 +0200, Jan Engelhardt wrote:
>
> >+static inline int svc_msnfs(struct svc_fh *ffhp)
> >+{
> >+#ifdef MSNFS
> >+ return (ffhp->fh_export->ex_flags & NFSEXP_MSNFS);
> >+#else
> >+ return 0;
> >+#endif
> >+}
>
> The name looks kinda confusing. msnfs? almost makes you think
> what's got microsoft to do with it..
I'd give it a better name if I had any idea what it means. :)
The macros and names are all preexisting. I just took the liberty of
pulling the #ifdef out into a function because the code got very
unreadable with the other modifications that I need.
If it were some kind of larger API, we could come up with something
better. But, for a single isolated user, I think it is OK.
-- Dave
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]