From: Andrew Morton <[email protected]> fs/nfsd/nfsctl.c: In function 'write_filehandle': fs/nfsd/nfsctl.c:301: warning: 'maxsize' may be used uninitialized in this function Cc: Neil Brown <[email protected]> Signed-off-by: Andrew Morton <[email protected]> Signed-off-by: "J. Bruce Fields" <[email protected]> --- fs/nfsd/nfsctl.c | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/fs/nfsd/nfsctl.c b/fs/nfsd/nfsctl.c index d135f5f..77dc989 100644 --- a/fs/nfsd/nfsctl.c +++ b/fs/nfsd/nfsctl.c @@ -298,7 +298,7 @@ static ssize_t write_filehandle(struct file *file, char *buf, size_t size) * qword quoting is used, so filehandle will be \x.... */ char *dname, *path; - int maxsize; + int uninitialized_var(maxsize); char *mesg = buf; int len; struct auth_domain *dom; -- 1.5.3.rc5.19.g0734d - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- [PATCH 13/15] knfsd: remove code duplication in nfsd4_setclientid()
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 13/15] knfsd: remove code duplication in nfsd4_setclientid()
- References:
- nfs server patches for review
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 01/15] nfsd: tone down inaccurate dprintk
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 02/15] nfsd: remove unused cache_for_each macro
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 03/15] nfsd: fix horrible indentation in nfsd_setattr
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 04/15] knfsd: delete code made redundant by map_new_errors
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 05/15] knfsd: cleanup of nfsd4 cmp_* functions
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 06/15] knfsd: demote some printk()s to dprintk()s
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 07/15] knfsd: nfs4 name->id mapping not correctly parsing negative downcall
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 08/15] knfsd: spawn kernel thread to probe callback channel
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 09/15] knfsd: move nfsv4 slab creation/destruction to module init/exit
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 10/15] knfsd: Validate filehandle type in fsid_source
- From: "J. Bruce Fields" <[email protected]>
- [PATCH 11/15] knfsd: fix callback rpc cred
- From: "J. Bruce Fields" <[email protected]>
- nfs server patches for review
- Prev by Date: [PATCH 09/15] knfsd: move nfsv4 slab creation/destruction to module init/exit
- Next by Date: [PATCH 14/15] svcgss: move init code into separate function
- Previous by thread: [PATCH 11/15] knfsd: fix callback rpc cred
- Next by thread: [PATCH 13/15] knfsd: remove code duplication in nfsd4_setclientid()
- Index(es):