Hi Ingo,
the RT patches for .22 and .23 are passing an incorrect parameter to
rebalance_domains.
I had this queued up for a few days - its still wrong in .22 and .23 RT
patches.
Same issue has been fixed in mainline by:
diff-tree de0cf899bbf06b6f64a5dce9c59d74c41b6b4232 (from
5d2b3d3695a841231b65b55
Author: Oleg Nesterov <[email protected]>
Date: Sun Aug 12 18:08:19 2007 +0200
sched: run_rebalance_domains: s/SCHED_IDLE/CPU_IDLE/
rebalance_domains(SCHED_IDLE) looks strange (typo), change it to
CPU_IDLE.
the effect of this bug was slightly more agressive idle-balancing on
SMP than intended.
Signed-off-by: Oleg Nesterov <[email protected]>
Signed-off-by: Ingo Molnar <[email protected]>
Thanks,
Sven
This parameter was missed when SCHED_IDLE was replaced by CPU_IDLE.
Fixed in mainline by:
commit de0cf899bbf06b6f64a5dce9c59d74c41b6b4232
Author: Oleg Nesterov <[email protected]>
Date: Sun Aug 12 18:08:19 2007 +0200
signed-off-by: Sven-Thorsten Dietrich <[email protected]>
Index: linux-2.6.22.1-rt9-broken-out/kernel/sched.c
===================================================================
--- linux-2.6.22.1-rt9-broken-out.orig/kernel/sched.c
+++ linux-2.6.22.1-rt9-broken-out/kernel/sched.c
@@ -3479,7 +3479,7 @@ static void run_rebalance_domains(struct
if (need_resched())
break;
- rebalance_domains(balance_cpu, SCHED_IDLE);
+ rebalance_domains(balance_cpu, CPU_IDLE);
rq = cpu_rq(balance_cpu);
if (time_after(this_rq->next_balance, rq->next_balance))
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]