Mathieu Desnoyers <[email protected]> writes:
> [...]
> +A marker placed in your code provides a hook to call a function (probe) that
> +you can provide at runtime. A marker can be "on" (a probe is connected to it)
> +or "off" (no probe is attached). When a marker is "off" it has no
> +effect. [...]
Add something like, ", except for a (how?) small time/space penalty."
> +[...]
> +trace_mark(subsystem_event, "%d %s", someint, somestring);
> +Where :
> +- subsystem_event is an identifier unique to your event
> + - subsystem is the name of your subsystem.
> + - event is the name of the event to mark.
> +[...]
It would be useful to clarify that this "subsystem_event" scheme is
only a suggested naming convention intended to limit collisions.
> +Connecting a function (probe) to a marker is done by providing a
> probe +(function to call) for the specific marker through
> marker_probe_register() and +can be activated by calling
> marker_arm().
It would help to spell out the nature of the marker namespace. Is it
global to the kernel? Per-module? Are conflicting "subsystem_event"
names but different format strings considered separate markers?
> + [...] Marker disactivation [...]
"deactivation"
- FChE
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]