On Tue, Aug 07, 2007 at 03:25:05PM -0600, Eric W. Biederman wrote: > > Now that sysfs no longer uses lookup_one_len_kern the function has > no users so remove it from the kernel. Making namei.c just a little > easier to read. > > Signed-off-by: Eric W. Biederman <ebiederm@xmission.com> Oh.. you're killing lookup_one_len_kern(). In that case, I think the previous one is okay too. Acked-by: Tejun Heo <htejun@gmail.com> -- tejun - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- References:
- [PATCH 06/25] sysfs: Simplify readdir.
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 07/25] sysfs: Rewrite sysfs_drop_dentry.
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 08/25] sysfs: Implement __sysfs_get_dentry
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 09/25] sysfs: Move sysfs_get_dentry below __sysfs_get_dentry
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 10/25] sysfs: Rewrite sysfs_get_dentry in terms of __sysfs_get_dentry
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 11/25] sysfs: Remove s_dentry
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 12/25] sysfs: Introduce sysfs_rename_mutex
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 13/25] sysfs: Simply sysfs_get_dentry
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 14/25] sysfs: Don't use lookup_one_len_kern
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 15/25] vfs: Remove lookup_one_len_kern
- From: ebiederm@xmission.com (Eric W. Biederman)
- [PATCH 06/25] sysfs: Simplify readdir.
- Prev by Date: Re: [PATCH 14/25] sysfs: Don't use lookup_one_len_kern
- Next by Date: Re: [PATCH] serial inter-character timeout usage with async io
- Previous by thread: Re: [PATCH 17/25] sysfs: Rewrite rename in terms of sysfs dirents
- Next by thread: Re: [PATCH 14/25] sysfs: Don't use lookup_one_len_kern
- Index(es):
![]() |