On Mon, 2007-07-16 at 16:15 -0700, Jeremy Fitzhardinge wrote:
> plain text document attachment (usermodehelper-split-init.patch)
> Rather than having hundreds of variations of call_usermodehelper for
> various pieces of usermode state which could be set up, split the
> info allocation and initialization from the actual process execution.
>
> This means the general pattern becomes:
> info = call_usermodehelper_setup(path, argv, envp); /* basic state */
> call_usermodehelper_<SET EXTRA STATE>(info, stuff...); /* extra state */
> call_usermodehelper_exec(info, wait); /* run process and free info */
The patch seems fine, but the names are awkward. They've always been
awkward (it's *userspace* helper, not *usermode* helper), but this just
shines a bright light on them.
So how about:
call_usermodehelper_setup -> create_userspace_helper
call_usermodehelper_<SET_EXTRA_STATE> -> userspace_helper_...
call_usermodehelper_exec -> run_userspace_helper
I can do that as a separate patch if you prefer (but it'd be nice to
have it in the same merge window so the interface only churns once).
Rusty.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]