Jan Engelhardt wrote: >> + >> +#define A20_TEST_ADDR (4*0x80) >> +#define A20_TEST_SHORT 32 >> +#define A20_TEST_LONG 2097152 /* 2^21 */ > > Maybe...? > #define A20_TEST_LONG (1 << 21) That makes it look like it's a magic value or bitmask, it's not. The value 2^21 is largely arbitrary, it's just what happened to be in the previous code. >> +/* Quick test to see if A20 is already enabled */ >> +static int a20_test_short(void) >> +{ >> + return a20_test(A20_TEST_SHORT); >> +} >> + >> +/* Longer test that actually waits for A20 to come on line; this >> + is useful when dealing with the KBC or other slow external circuitry. */ >> +static int a20_test_long(void) >> +{ >> + return a20_test(A20_TEST_LONG); >> +} > > To me looks like some of these (or other functions) could return bool. Does it matter? It will generate worse code. -hpa - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- References:
- x86 setup code rewrite in C
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 01/33] x86 setup: MAINTAINERS: formally take responsibility for the i386 boot code
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 02/33] hd.c: remove BIOS/CMOS queries
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 03/33] include/asm-i386/boot.h: This is <asm/boot.h>, not <linux/boot.h>
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 04/33] Unify the CPU features vectors between i386 and x86-64
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 05/33] Change CONFIG_X86_MINIMUM_CPU_MODEL to CONFIG_X86_MINIMUM_CPU_FAMILY
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 06/33] Clean up struct screen_info (<linux/screen_info.h>)
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 07/33] Use a new CPU feature word to cover all Intel features that are spread around
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 08/33] Define zero-page offset 0x1e4 as a scratch field, and use it
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 09/33] Make definitions for struct e820entry and struct e820map consistent
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 10/33] Make struct boot_params a real structure, and remove obsolete fields
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 11/33] x86-64: add CONFIG_PHYSICAL_ALIGN for consistency with i386
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 12/33] x86-64: add symbolic constants for the boot segment selectors
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 13/33] Header file to produce 16-bit code with gcc
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 14/33] Top header file for new x86 setup code
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 15/33] Simple bitops for the new x86 setup code.
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 16/33] String-handling functions for the new x86 setup code.
- From: "H. Peter Anvin" <hpa@zytor.com>
- [x86 setup 17/33] A20 handling code
- From: "H. Peter Anvin" <hpa@zytor.com>
- Re: [x86 setup 17/33] A20 handling code
- From: Jan Engelhardt <jengelh@computergmbh.de>
- x86 setup code rewrite in C
- Prev by Date: [git patches] libata updates
- Next by Date: Re: PCI probing changes
- Previous by thread: Re: [x86 setup 17/33] A20 handling code
- Next by thread: Re: [x86 setup 16/33] String-handling functions for the new x86 setup code.
- Index(es):
![]() |