Hi, This series of splice patches removes file_operations ->sendfile() from the kernel and converts do_sendfile() to use ->splice_read() to achieve the same function. -- Jens Axboe - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- [PATCH 15/18] sendfile: remove bad_sendfile() from bad_file_ops
- From: Jens Axboe <[email protected]>
- [PATCH 11/18] splice: divorce the splice structure/function definitions from the pipe header
- From: Jens Axboe <[email protected]>
- [PATCH 18/18] Remove remnants of sendfile()
- From: Jens Axboe <[email protected]>
- [PATCH 17/18] ext2 xip: replace sendfile with splice
- From: Jens Axboe <[email protected]>
- [PATCH 16/18] splice: completely document external interface with kerneldoc
- From: Jens Axboe <[email protected]>
- [PATCH 14/18] shmem: convert to using splice instead of sendfile()
- From: Jens Axboe <[email protected]>
- [PATCH 4/18] sendfile: remove .sendfile from filesystems that use generic_file_sendfile()
- From: Jens Axboe <[email protected]>
- [PATCH 13/18] relay: use splice_to_pipe() instead of open-coding the pipe loop
- From: Jens Axboe <[email protected]>
- [PATCH 8/18] sendfile: convert nfs to using splice_read()
- From: Jens Axboe <[email protected]>
- [PATCH 10/18] splice: relay support
- From: Jens Axboe <[email protected]>
- [PATCH 12/18] pipe: allow passing around of ops private pointer
- From: Jens Axboe <[email protected]>
- [PATCH 7/18] loop: convert to using splice_direct_to_actor() instead of sendfile()
- From: Jens Axboe <[email protected]>
- [PATCH 9/18] sendfile: convert nfsd to splice_direct_to_actor()
- From: Jens Axboe <[email protected]>
- [PATCH 6/18] splice: add void cookie to the actor data
- From: Jens Axboe <[email protected]>
- [PATCH 1/18] splice: abstract out actor data
- From: Jens Axboe <[email protected]>
- [PATCH 2/18] vmsplice: add vmsplice-to-user support
- From: Jens Axboe <[email protected]>
- [PATCH 3/18] sys_sendfile: switch to using ->splice_read, if available
- From: Jens Axboe <[email protected]>
- [PATCH 5/18] sendfile: kill generic_file_sendfile()
- From: Jens Axboe <[email protected]>
- [PATCH 15/18] sendfile: remove bad_sendfile() from bad_file_ops
- Prev by Date: Re: [shm][hugetlb] Fix get_policy for stacked shared memory files
- Next by Date: [PATCH 5/18] sendfile: kill generic_file_sendfile()
- Previous by thread: [KJ PATCH] Replacing memcpy(dest,src,PAGE_SIZE) with copy_page(dest,src) in arch/i386/mm/init.c
- Next by thread: [PATCH 5/18] sendfile: kill generic_file_sendfile()
- Index(es):