Re: 2.6.22-rc4-mm1 - 'lvm vgscan' busticated again...

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


[email protected] wrote:
> On Thu, 07 Jun 2007 15:44:56 +0900, Tejun Heo said:
>> [email protected] wrote:
>>> On Wed, 06 Jun 2007 02:07:37 PDT, Andrew Morton said:
> .6.22-rc4-mm1/
>>> This one died a horrid death at boot time - console log indicates it found 
> the
>>> hard drive OK, found the 2 partitions on it.  But when the initrd ran a
>>> 'lvm vgscan', it didn't find the LVM2 space on /dev/sda2, so it panic'ed wh
> en
>>> it fell off the end of the initrd because the root= wasn't there.
>>> My first guess for blame:
>>> gregkh-driver-sysfs-allocate-inode-number-using-ida.patch
>>> as that's awfully similar to gregkh-driver-sysfs-fix-i_ino-handling-in-sysfs.patch
>>> that broke 'lvm vgscan' for me in the same way on 21-rc7-mm[12].
>>> I'll hopefully get a chance to revert that one and test later today - a quick
>>> 'patch -p1 -R --dry-run' shows a number of conflicts that will need hand-fixing
>>> at the very least.
>> Did rc3-mm1 work?  Can you find out the first broken -mm?
> 21-rc5-mm2 worked, -rc6-mm* were busticated for other reasons on my laptop,
> 21-rc7-mm[12] were broken, 21-mm1 through 21-rc3-mm1 worked, -rc4-mm1 broke,
> and -rc4-mm2 works. I could bisect through -rc4-mm1 if it's deemed useful,
> Andrew just pushed -mm2 before I had a chance.

Thanks.  The offending patch was


Which is pulled from -mm2.  Jiri Slaby reports that turning on
SYSFS_DEPRECATED fixes the problem.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at
Please read the FAQ at

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux