This change is based on recent discussions of the JFFS2 code relying on
constants defined in the private zlib header zutil.h
The result of this discussion is to change the use of the constant into
a 'Magic Number' (according to Mark Adler this number is part of the standard
and will never change - defined in RFC 1950)
Signed-off-by: Daniel Hazelton <[email protected]>
diff --git a/fs/jffs2/compr_zlib.c b/fs/jffs2/compr_zlib.c
index 2b87fcc..9f1b935 100644
--- a/fs/jffs2/compr_zlib.c
+++ b/fs/jffs2/compr_zlib.c
@@ -16,7 +16,6 @@
#include <linux/kernel.h>
#include <linux/slab.h>
#include <linux/zlib.h>
-#include <linux/zutil.h>
#include "nodelist.h"
#include "compr.h"
@@ -154,7 +153,7 @@ static int jffs2_zlib_decompress(unsigned char *data_in,
/* If it's deflate, and it's got no preset dictionary, then
we can tell zlib to skip the adler32 check. */
- if (srclen > 2 && !(data_in[1] & PRESET_DICT) &&
+ if (srclen > 2 && !(data_in[1] & 0x20) &&
((data_in[0] & 0x0f) == Z_DEFLATED) &&
!(((data_in[0]<<8) + data_in[1]) % 31)) {
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]