On Wed, May 30, 2007 at 08:41:56AM +0200, Stefan Richter wrote:
> From: Stefan Richter <[email protected]>
> Subject: fs: clarify "dummy" member in struct inodes_stat_t
>
> Found by Robert P. J. Day: The role of inodes_stat_t.dummy wasn't clear
> and one might be tempted to remove it. Give it a better name and add a
> comment.
>
> Signed-off-by: Stefan Richter <[email protected]>
> ---
> Only quickly compile-tested.
>
> Index: linux/include/linux/fs.h
> ===================================================================
> --- linux.orig/include/linux/fs.h
> +++ linux/include/linux/fs.h
> @@ -44,7 +44,7 @@ extern int get_max_files(void);
> struct inodes_stat_t {
> int nr_inodes;
> int nr_unused;
> - int dummy[5];
> + int reserved[5]; /* for sysctl and procfs ABI compatibility */
> };
> extern struct inodes_stat_t inodes_stat;
Considering that we export this struct to usespace, I don't think
renaming a member without a good reason is a good idea (but adding a
comment makes sense).
> Stefan Richter
cu
Adrian
--
"Is there not promise of rain?" Ling Tan asked suddenly out
of the darkness. There had been need of rain for many days.
"Only a promise," Lao Er said.
Pearl S. Buck - Dragon Seed
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]