Re: 2.6.22-rc1-mm1

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Mel Gorman wrote:
> On Wed, 16 May 2007, H. Peter Anvin wrote:
>> Correction, does *this patch* do it for you?
> With these two patches in combination, previously failing machines
> elm3b6 (x86_64 on and a modern x86 built a kernel and
> booted correctly.
> elm3b132 and elm3b132 (x86 numaq on built with these
> patches but silently fail on boot with no output via earlyprintk.
> According to, this failure occurs with git-newsetup
> reverted so it is a separate problem.

Ok, I've been following up on this failure on elm3b132/3.  I moved
forward to v2.6.22-rc2-mm1 and that also fails.  I ran a bisection on
the git-newsetup patch in as in -mm and basically it came down to the
first patch, ie. any and all of this tree stops the boot.

I just tried reproducing git-newsetup boot failures with the latest
version of your tree (369f16fdd423d79640c4390915e6ab71189cb497) and that
also fails.

Fails in this context is hard boot failure after loading the kernel and
before anything is printed.  I also added a printf to the top of main()
in boot/main.c and it doesn't come out, not that I really know if that
means it got there or not.

Any suggestions how to debug this puppy?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at
Please read the FAQ at

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux