The following patches consist of mostly cleanups of the Unionfs code, as well as fixes for several harder to hit bugs (resource/memory leaks). As before, there is a git repo at: git://git.kernel.org/pub/scm/linux/kernel/git/jsipek/unionfs.git (master.kernel.org:/pub/scm/linux/kernel/git/jsipek/unionfs.git) There are 21 new commits: Unionfs: Correctly decrement refcounts of mnt's upon branch management Unionfs: Removed a trailing whitespace Unionfs: Actually catch bad use of unionfs_mnt{get,put} Unionfs: Remove defunct unionfs_put_inode super op Unionfs: Documentation update regarding overlapping branches and new lookup code Unionfs: Disallow setting leftmost branch to readonly Unionfs: Use krealloc instead of open-coding the functionality Unionfs: Call realloc unconditionally Unionfs: Don't leak resources when copyup fails partially Unionfs: Prefix external functions with 'extern' properly Unionfs: Combine unionfs_write with __unionfs_write. Unionfs: Move unionfs_query_file to commonfops.c Unionfs: Rename our "do_rename" to __unionfs_rename Unionfs: Rename Unionfs's double_lock_dentry to avoid confusion Unionfs: Consistent pointer declaration spacing Unionfs: Added numerous comments Unionfs: Cleanup of strings and comments Unionfs: Add missing copyright notices Unionfs: Every printk should prefix with "unionfs: " consistently Unionfs: Coding style fixes Unionfs: Tiny documentation fixups Thanks, Josef 'Jeff' Sipek <[email protected]> - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- [PATCH 18/21] Unionfs: Remove defunct unionfs_put_inode super op
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 13/21] Unionfs: Don't leak resources when copyup fails partially
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 02/21] Unionfs: Coding style fixes
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 03/21] Unionfs: Every printk should prefix with "unionfs: " consistently
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 06/21] Unionfs: Added numerous comments
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 05/21] Unionfs: Cleanup of strings and comments
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 08/21] Unionfs: Rename Unionfs's double_lock_dentry to avoid confusion
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 10/21] Unionfs: Move unionfs_query_file to commonfops.c
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 12/21] Unionfs: Prefix external functions with 'extern' properly
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 11/21] Unionfs: Combine unionfs_write with __unionfs_write.
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 07/21] Unionfs: Consistent pointer declaration spacing
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 16/21] Unionfs: Disallow setting leftmost branch to readonly
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 09/21] Unionfs: Rename our "do_rename" to __unionfs_rename
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 17/21] Unionfs: Documentation update regarding overlapping branches and new lookup code
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 19/21] Unionfs: Actually catch bad use of unionfs_mnt{get,put}
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 14/21] Unionfs: Call realloc unconditionally
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 20/21] Unionfs: Removed a trailing whitespace
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 15/21] Unionfs: Use krealloc instead of open-coding the functionality
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 21/21] Unionfs: Correctly decrement refcounts of mnt's upon branch management
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 04/21] Unionfs: Add missing copyright notices
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 01/21] Unionfs: Tiny documentation fixups
- From: "Josef 'Jeff' Sipek" <[email protected]>
- [PATCH 18/21] Unionfs: Remove defunct unionfs_put_inode super op
- Prev by Date: Re: 2.6.21-mm2: ACPI exception on resume
- Next by Date: [PATCH 01/21] Unionfs: Tiny documentation fixups
- Previous by thread: Adrian Bunk
- Next by thread: [PATCH 01/21] Unionfs: Tiny documentation fixups
- Index(es):