>> -DEFINE_PER_CPU(struct tss_struct, init_tss)
>>____cacheline_internodealigned_in_smp = INIT_TSS;
>> +DEFINE_PER_CPU_SHARED_ALIGNED(struct tss_struct, init_tss) =
INIT_TSS;
>Good work but could we call this something shorter?
>Like
>DEFINE_CPU_SHARED(...)
The PER_CPU_SHARED_ALIGNED is corresponding to
.data.per_cpu.shared_aligned section which has all shared and aligned
percpu data.
In future, another section .data.per_cpu.shared and its macro
DEFINE_PER_CPU_SHARED might be added for shared but not aligned.
BTW, DEFINE_PER_CPU_SHARED_ALIGNED is already getting shorter than
pervious version.
Thanks.
-Fenghua
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]