On Tue, May 08, 2007 at 05:41:59PM -0700, Andrew Morton wrote:
> On Tue, 8 May 2007 20:48:45 +0100
> Alasdair G Kergon <[email protected]> wrote:
> > +#define BIO_LIST(bl) \
> > + struct bio_list bl = BIO_LIST_INIT
> BIO_LIST is a strange name for something which initialises storage.
Those came by analogy with list.h, with list_head -> bio_list:
#define LIST_HEAD(name) \
struct list_head name = LIST_HEAD_INIT(name)
We could use something like INIT_BIO_LIST(bl) for that, but perhaps it would be
more readable always written out in full?
struct bio_list bl = BIO_LIST_INIT;
Alasdair
--
[email protected]
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]