Oliver Neukum napsal(a):
> Hi,
>
> I suggest that the coding style should state that if either branch of
> an 'if' statement needs braces, both branches should use them.
>
> Regards
> Oliver
> Signed-off-by: Oliver Neukum <[email protected]>
> ----
>
> --- a/Documentation/CodingStyle 2007-04-20 13:08:17.000000000 +0200
> +++ b/Documentation/CodingStyle 2007-04-20 13:16:14.000000000 +0200
> @@ -160,6 +160,21 @@
> 25-line terminal screens here), you have more empty lines to put
> comments on.
>
> +Do not unnecessarily use braces where a single statement will do.
> +
> +if (condition)
> + action();
> +
> +This does not apply if one branch of a conditional statement is a single
> +statement. Use braces in both branches.
Why, what's wrong with
if (condition) {
do_this();
do_that();
} else
otherwise();
? It's more readable/nicer in my eyes than
> +if (condition) {
> + do_this();
> + do_that();
> +} else {
> + otherwise();
> +}
> +
and not only in mine according to fast grep.
regards,
--
http://www.fi.muni.cz/~xslaby/ Jiri Slaby
faculty of informatics, masaryk university, brno, cz
e-mail: jirislaby gmail com, gpg pubkey fingerprint:
B674 9967 0407 CE62 ACC8 22A0 32CC 55C3 39D4 7A7E
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]