Re: [BUG] 2.6.21: Kernel won't boot with either/both of CONFIG_NO_HZ, CONFIG_HIGH_RES_TIMERS

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Thomas Gleixner wrote:
On Tue, 2007-05-01 at 10:13 -0400, Mark Lord wrote:
Of possible interest is that the bottom of the 25line screen capture
differs somewhat from the 50line capture.. see for yourself.
This is 100% consistent from boot to boot.

Using CONFIG_DETECT_SOFTLOCKUP=y eliminates the problem,
so that's really got to be a huge clue, somehow ?
I twisted my brain, why the watchdog thread might change the problem and
I think I have a rough idea of the scenario.
Can you apply the following patch, which prints out the CPU on which the
kernel messages are generated and upload the screenshot when the hang
happens ? Oh, please enable CONFIG_PRINTK_TIME or add "time" to the
kernel commandline.
Done, and done.
And I managed to capture more of the boot messages, too.
This new capture is in the "sequence" subdir at the previous link.

Cheers
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux