>+ testb $8, %dxl /* rdx is 3,5,6,7,9..15 */
Could you use the more conventional name %dl (or whatever is being meant)
here?
>+.L42:
>+ prefetchnta 128(%rsi)
I think I commented similarly on a previous version of the patch: This will
- result in still bringing the first 128 bytes into the cache
- prevent caching of memory beyond the buffer being dealt with
>+ sfence
Similarly, I continue to believe this is wrong here (again I commented before
that this is likely unnecessary, or if at all, it should be an lfence).
>+ orl %edx, %edx
Operations of this type generally should use 'test', not 'or' or 'and'.
Jan
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]