Here are the patches to support the relocatable kernel on x86-64. All done by Eric Biederman and Vivek Goyal. Following i386. Also includes lots of cleanup to various boot paths. Vivek already posted them a couple of time. Please review. -Andi - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- [PATCH] [7/22] x86_64: cleanup segments
- From: Andi Kleen <[email protected]>
- [PATCH] [8/22] x86_64: Add EFER to the register set saved by save_processor_state
- From: Andi Kleen <[email protected]>
- [PATCH] [1/22] x86_64: dma_ops as const
- From: Andi Kleen <[email protected]>
- [PATCH] [6/22] x86_64: modify copy_bootdata to use virtual addresses
- From: Andi Kleen <[email protected]>
- [PATCH] [5/22] x86_64: Fix early printk to use standard ISA mapping
- From: Andi Kleen <[email protected]>
- [PATCH] [4/22] x86_64: Clean up the early boot page table
- From: Andi Kleen <[email protected]>
- [PATCH] [11/22] x86_64: wakeup.S rename registers to reflect right names
- From: Andi Kleen <[email protected]>
- [PATCH] [9/22] x86_64: 64bit PIC SMP trampoline
- From: Andi Kleen <[email protected]>
- [PATCH] [12/22] x86_64: wakeup.S misc cleanups
- From: Andi Kleen <[email protected]>
- [PATCH] [14/22] x86_64: Modify discover_ebda to use virtual addresses
- From: Andi Kleen <[email protected]>
- [PATCH] [16/22] x86: Move swsusp __pa() dependent code to arch portion
- From: Andi Kleen <[email protected]>
- [PATCH] [15/22] x86_64: Remove the identity mapping as early as possible
- From: Andi Kleen <[email protected]>
- [PATCH] [19/22] x86_64: Relocatable Kernel Support
- From: Andi Kleen <[email protected]>
- [PATCH] [17/22] x86_64: do not use virt_to_page on kernel data address
- From: Andi Kleen <[email protected]>
- [PATCH] [20/22] x86_64: build-time checking
- From: Andi Kleen <[email protected]>
- [PATCH] [21/22] x86_64: Extend bzImage protocol for relocatable bzImage
- From: Andi Kleen <[email protected]>
- [PATCH] [22/22] x86_64: Move cpu verification code to common file
- From: Andi Kleen <[email protected]>
- [PATCH] [18/22] x86: __pa and __pa_symbol address space separation
- From: Andi Kleen <[email protected]>
- [PATCH] [13/22] x86_64: 64bit ACPI wakeup trampoline
- From: Andi Kleen <[email protected]>
- [PATCH] [10/22] x86_64: Get rid of dead code in suspend resume
- From: Andi Kleen <[email protected]>
- [PATCH] [3/22] x86_64: Kill temp boot pmds
- From: Andi Kleen <[email protected]>
- [PATCH] [2/22] x86_64: Assembly safe page.h and pgtable.h
- From: Andi Kleen <[email protected]>
- [PATCH] [7/22] x86_64: cleanup segments
- Prev by Date: Re: 2.6.21 known regressions (v2) (for -stable team)
- Next by Date: Re: checkpatch, a patch checking script.
- Previous by thread: Your /etc/kernel-img.conf needs to be updated
- Next by thread: [PATCH] [2/22] x86_64: Assembly safe page.h and pgtable.h
- Index(es):