Re: [PATCH] v4: merged utimensat implementation

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Apr 27, 2007 at 11:23:58AM -0400, Ulrich Drepper wrote:
> I took Alexey's lutimes patches and merged it with the utimensat patch.
> Fortunately Alexey already did most of the work, the conversion to
> timespec.  I just changed the name of the syscall, made the flag part
> of the syscall parameters, and did away with the old do_utimes definition
> (the new do_utimes takes a timespec and a flag now).  All five patches
> patches are rolled into one.

erm, utime(2) cleanup is technically independent from all this nanosecond
business, but ok.

> --- a/arch/alpha/kernel/osf_sys.c
> +++ b/arch/alpha/kernel/osf_sys.c
> @@ -955,15 +955,25 @@ osf_setitimer(int which, struct itimerval32 __user *in, struct itimerval32 __use
>  asmlinkage int
>  osf_utimes(char __user *filename, struct timeval32 __user *tvs)
>  {
> -	struct timeval ktvs[2];
> +	struct timespec tv[2];

It should be tiny little bit nicer to call them "ts[2]" because they're
timeSpecs.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux