On Wed, April 25, 2007 08:19, Duncan Sands wrote:
> Hi Simon,
>
>> static ssize_t cxacru_sysfs_showattr_dB(s16 value, char *buf)
>> {
>> - if (unlikely(value < 0)) {
>> - return snprintf(buf, PAGE_SIZE, "%d.%02u\n",
>> - value / 100, -value % 100);
>> - } else {
>> - return snprintf(buf, PAGE_SIZE, "%d.%02u\n",
>> - value / 100, value % 100);
>> - }
>> + return snprintf(buf, PAGE_SIZE, "%u.%02u\n",
>> + value / 100, abs(value) % 100);
>
> shouldn't this be "%d.%02u\n"?
Yes, I'll send an updated patch this evening, unless Andrew adds the change himself by then.
>> + static char *str[] = { "no", "yes" };
> ...
>> + return snprintf(buf, PAGE_SIZE, "%s\n", str[value]);
>
> This could be
> static char *str[] = { "no\n", "yes\n" };
> ...
> return snprintf(buf, PAGE_SIZE, str[value]);
> I'm not saying that it's better, just a remark!
The \ns in the larger arrays were making them less readable.
--
Simon Arlott
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]