On Monday, 23 April 2007 15:17, Gautham R Shenoy wrote:
> On Sun, Apr 22, 2007 at 09:39:26PM +0200, Rafael J. Wysocki wrote:
> > @@ -63,9 +100,9 @@ static inline int thaw_process(struct ta
> > */
> > static inline void frozen_process(struct task_struct *p)
> > {
> > - p->flags |= PF_FROZEN;
> > + set_frozen_flag(p);
> > wmb();
> > - clear_tsk_thread_flag(p, TIF_FREEZE);
> > + do_not_freeze(p);
>
> We may want to rename do_not_freeze to something else. It kind of
> looks weird calling do_not_freeze(p) after setting the frozen flag!
>
> Probably, just a matter of taste :-)
Hmm, I wanted to avoid changing the existing names in this patch, but in this
particular case you are obviously right. I'll change that to
clear_freeze_flag().
Greetings,
Rafael
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]