Andrew, unless you stop me right now, I am going to send the following
patches in addition:
[PATCH] kill cancel_rearming_delayed_workqueue()
cancel_rearming_delayed_workqueue(wq, dwork) does not
need the first parameter, it could be figured out from
dwork. So we can rename it to cancel_rearming_delayed_work
after the simple change and fix all callers.
In other words:
- cancel_rearming_delayed_work(dwork) will work
for any workqueue, not just keventd_wq.
- all callers of cancel_rearming_delayed_workqueue()
will be converted to use it.
No? This breaks the public interface, but we already did
this recently ...
[PATCH] kill flush_work_keventd()
The same is true for flush_work(), it doesn't need the
"struct workqueue_struct *wq" parameter. I missed this
fact when I was doing flush_work().
This change is obviously good to do before flush_work()
goes to mainline.
Also, I think the name "flush_work" is very bad. Isn't
it better to rename it as well?
cancel_work? cancel_work_sync? whatever.
[PATCH] bonus: mark kernel/workqueue.c as CONFIG_EXPERIMENTAL
too many non-reviewed changes ...
Oleg.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]