Randy Dunlap wrote:
On Sun, 21 Jan 2007 15:07:37 -0600 Jay Cliburn wrote:
[snip]
+ value = ioread16(hw->hw_addr + REG_PCIE_CAP_LIST);
+ return ((value & 0xFF00) == 0x6C00) ? 0 : 1;
Are there defines or enums for these?
Fewer magic numbers would be nice/helpful/readable.
[snip]
+ s32 ret;
+ ret = atl1_write_phy_reg(hw, 29, 0x0029);
Fewer magic numbers?
Unfortunately, we don't have a spec. This is how the vendor coded it.
[snip]
+
+int enable_msi;
+module_param(enable_msi, int, 0444);
+MODULE_PARM_DESC(enable_msi, "Enable PCI MSI");
Hm, I thought that we didn't want individual drivers having MSI config
options...
Luca? This one was yours IIRC. Care to chime in?
Randy, thank you for the review.
Jay
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]