Re: lots of code could be simplified by using ARRAY_SIZE()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Jan Engelhardt wrote:
> On Dec 16 2006 08:09, Robert P. J. Day wrote:
>> On Sat, 16 Dec 2006, Pavel Machek wrote:
>>>> but we already have, from "include/linux/kernel.h":
>>>>
>>>>   #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
>>> Hmmm. quite misleading name :-(. ARRAY_LEN would be better.

"Size", "length", "width", "depth" is all the same in that one needs to
know the unit of measurement. The unit of measurement of ARRAY_SIZE is
one array member. This makes it useful as a bound for [ ] pointer
arithmetic which uses the same unit.

If you want to look at it from a slightly higher level of abstraction
and want to avoid the ambiguity WRT units of measurement (C programs
most often use Byte as unit for data size), consider the unitless
(cardinal) ARRAY_INDEX_BOUND or ARRAY_CARDINALITY. (In a language which
starts array indexes at 1 instead of 0, it could also be called
ARRAY_HIINDEX.)

But fortunately...

>> i suspect it's *way* too late to make that kind of change, given that
>> "ARRAY_SIZE" is firmly ensconced in countless places in the source
>> tree and that would be a major, disruptive change.
>>
>> even *i* wouldn't try to promote that idea.  :-)
> 
> You know, you could always make it compat for a while, but that requires
> approval from Linus I suppose /* heh, heh */
> 
> I don't even know if this will compile everywhere,
> but I hope you can figure out the idea...
> 
> #define ARRAY_SIZE(x) (print_warning(), sizeof(x) / sizeof(*x))
> #define ARRAY_LEN(x)  (sizeof(x) / sizeof(*x))
> extern ...
> void print_warning(void) {
>     printk("Don't use ARRAY_SIZE anymore, it will go away\n");
> }

...those who know that the ARRAY_SIZE macro is available also know what
it means and how to use it. Therefore there is no need to rename this macro.
-- 
Stefan Richter
-=====-=-==- ==-- =---=
http://arcgraph.de/sr/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux