Re: lots of code could be simplified by using ARRAY_SIZE()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, 14 Dec 2006, Zach Brown wrote:

> >  there are numerous places throughout the source tree that
> > apparently calculate the size of an array using the construct
> > "sizeof(fubar)/sizeof(fubar[0])". see for yourself:

> >  $ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" *
>
> Indeed, there seems to be lots of potential clean-up there.
> Including duplicate macros like:
>
> ./drivers/ide/ide-cd.h:#define ARY_LEN(a) ((sizeof(a) / sizeof(a[0])))

not surprisingly, i have a script "arraysize.sh":

============================================================
#!/bin/sh

DIR=$1

# grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" ${DIR}
# grep -Erl "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" ${DIR}

for f in $(grep -Erl "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" ${DIR}) ; do
  echo "ARRAY_SIZE()ing $f ..."
  perl -pi -e "s|sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)|ARRAY_SIZE\(\1\)|" $f
done
===========================================================

  anyone who's interested can run it with a single argument of the
directory to process, eg.:

  $ arraysize.sh fs
  $ arraysize.sh drivers
  $ arraysize.sh .		# entire tree, of course

it's just a first pass, but it seems to produce reasonable code.

rday
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux