Am Montag, 4. Dezember 2006 17:57 schrieb Alan Stern:
> I was referring to sysfs_remove_file(), not sysfs_open_file() -- I agree
> that getting rid of the check_perm() routine is good. But this isn't:
>
> > void sysfs_remove_file(struct kobject * kobj, const struct attribute * attr)
> > {
> > - sysfs_hash_and_remove(kobj->dentry,attr->name);
> > + struct dentry *d = kobj->dentry;
> > +
> > + sysfs_hash_and_remove(d, attr->name);
> > }
>
> There's no apparent advantage to introducing the local variable d, either
> in terms of execution speed or readability. (Although the original source
> line should have a space after the comma.)
Yes, correct, it is a remainder of using the dentry twice in that routine.
Then a local variable saved a recomputation. I can redo it, sorry.
However, it doesn't affect correctness, so I won't distract further by
doing an essentially cosmetic change.
Regards
Oliver
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]