On Mon, 20 Nov 2006, Stefan Richter wrote:
> David Howells wrote:
> > Separate delayable work items from non-delayable work items be splitting them
> > into a separate structure (dwork_struct), which incorporates a work_struct and
> > the timer_list removed from work_struct.
> ...
> > if (!delay)
> > - rc = queue_work(ata_wq, &ap->port_task);
> > + rc = queue_dwork(ata_wq, &ap->port_task);
> > else
> > rc = queue_delayed_work(ata_wq, &ap->port_task, delay);
> ...
>
> A consequent (if somewhat silly) name for queue_delayed_work would be
> queue_delayed_dwork, since it requires a struct dwork_struct.
Yes. Please don't use "dwork" as a name AT ALL. Not in "dwork_struct" and
not in "queue_dwork()".
"dwork" just sounds d[w]orky. More importantly, we don't use short-hand
that isn't obvious, unless there is some industry-standard and old meaning
to it that everybody understands. "delayed_work" may be more typing, but
anybody who needs to type things that fast had better slow down anyway to
_think_.
No excuses for short and unreadable names.
Linus
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]