> We originally had at91_set_gpio_direction() in the AT91 GPIO layer, and
> that seemed to cause confusion (eg, do I pass a 1 or 0 to enable output
> mode?)
I was thinking the __bitwise annotation on GPIO_IN and GPIO_OUT should
address that problem, but for some reason it isn't doing that. I must
be doing something wrong; even "sparse" isn't warning when passing a
bogus parameter.
> So I'd personally prefer to keep gpio_set_input() and
> gpio_set_output(). (alternative is "enable" instead of "set").
> I think it's more readable.
To be clear ... having two different function calls is a brand
new proposal. :)
Agreed on readable, and I do recall the problem. If I can't get
the __bitwise annotation to behave, that's how I'll do it.
- Dave
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]