On Tue, 17 Oct 2006 10:37:44 +0200
Cedric Le Goater <[email protected]> wrote:
> This patch replaces occurences of task->signal->session by a new
> process_session() helper routine.
>
> It will be useful for pid namespaces to abstract the session pid
> number.
hm.
> +static inline pid_t process_session(struct task_struct *tsk)
> +{
> + return tsk->signal->session;
> +}
> +
We should rename signal_struct.session to something else
(session_dont_use_me_directly) so that any code which accidentally fails to
use the wrapper will reliably fail to build.
That means that we'll also need a helper function to set this field.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]